Hoved Pc Og Mac Er e-post store og små bokstaver?

Er e-post store og små bokstaver?



Det er mye forvirring om e-postadressene er mellom store og små bokstaver. Noen sier at de er det, mens andre hevder at de ikke er det. Så hvem har rett? I denne artikkelen vil vi se på om e-postadresser er mellom store og små bokstaver.

Er e-post store og små bokstaver?

Hva lager en e-postadresse?

En e-postadresse består av tre deler - den lokale delen (også kjent som brukernavn), @ -tegnet og domenedelen. Hver del har sin egen rolle og er underlagt sitt eget regelsett. Her er en rask oversikt.

I henhold til standarden kan den lokale delen av e-postadressen være opptil 64 tegn lang og kan bestå av et begrenset sett med tegn. Disse inkluderer store og små bokstaver i Latin-alfabetet, tall fra 0 til 9, prikk og spesialtegn. Spesialtegnene inkluderer `[email protected] # $% ^ & * () _- + = [] {} ~. Den er koblet til domenedelen med @ -tegnet.

Domenedelen kan være opptil 255 tegn lang. Det kan inneholde bokstaver i det latinske alfabetet (både store og små bokstaver), tall fra 0 til 9 og bindestrek. Bindestreket kan ikke starte eller avslutte domenedelen.

Internasjonale symboler kan også brukes, men mer om det senere.

Er det store og små bokstaver?

Det riktige svaret på dette spørsmålet er både ja og nei. I følge RFC 5321 , den lokale delen av e-postadressen er mellom store og små bokstaver. Dette betyr at [te-postbeskyttet] i teorien ikke er det samme som [e-postbeskyttet] Imidlertid har e-postleverandører frihet til å behandle de lokale delene som både store og små bokstaver.

For eksempel er [e-postbeskyttet], [e-postbeskyttet] og [e-postbeskyttet] teoretisk forskjellige e-postadresser. Det er lett å se hvordan dette kan skape problemer og redusere brukeropplevelsen hvis en e-postserver valgte å behandle de lokale delene som store og små bokstaver. Derfor behandler mange leverandører den lokale delen av e-postadressen som liten bokstav.

hvordan du endrer språk i legendeserien

Når det gjelder domenedelen, RFC 1035 fastslår at det alltid er ufølsomt. Dette betyr at du kan skrive det med små, store bokstaver eller en hvilken som helst kombinasjon av de to, og e-posten din vil havne på samme adresse. I praktisk bruk er [e-postbeskyttet], [e-postbeskyttet] og [e-postbeskyttet] den samme e-postadressen.

I praksis

Mens e-postadresser bare er delvis store og små bokstaver, er det generelt trygt å tenke på dem som små og store bokstaver. Alle større leverandører, som Gmail, Yahoo Mail, Hotmail og andre, behandler de lokale delene av e-postadressene som små og store bokstaver. Når det er sagt, bør du sjekke reglene til e-postleverandøren du vil opprette en e-post med.

RFC 5321 anbefaler at nye e-postadresser opprettes med små bokstaver for å unngå potensielle forvirring og leveringsproblemer.

På den annen side, hvis din venn eller kollega har en e-postadresse med en kombinasjon av store og små bokstaver, anbefales det å skrive den slik den er når du sender dem en e-post. Unnlatelse av å gjøre dette kan føre til at e-posten ikke blir levert. Dette er imidlertid ikke et problem med store e-postleverandører som Gmail, Yahoo Mail, Hotmail og andre.

I tillegg er Gmail også ufølsom for punkter som finnes i den lokale delen av e-posten når det gjelder identifikasjon av brukerkonto. Dette betyr at hvis [e-postbeskyttet] -kontoen eksisterer, vil du ikke kunne registrere [e-postbeskyttet] eller [e-postbeskyttet]

Internasjonalisering

Opprinnelig kunne e-postadresser bare registreres med bokstavene i det latinske alfabetet, tall og et begrenset sett med spesielle ASCII-tegn. Imidlertid, den IETF (Internet Engineering Task Force) har senere utviklet regler og standarder for inkludering av internasjonale karakterer.

RFC6530 var den første til å inkludere og regulere bruken av internasjonale karakterer. RFC6531 utvidet på reglene og standardene. Deretter ble reglene og standardene oppdatert gjennom RFC6532 og RFC6533 .

Du kan nå registrere en e-postadresse ved hjelp av et bredt spekter av alfabeter, tegn og skript. Noen av de mest brukte inkluderer latinske tegn med diakritiske skrifter, gresk alfabet, tradisjonelle kinesiske tegn, japanske tegn (hiragana, katakana og kanji), kyrillisk alfabet, flere indiske skrifter, samt en rekke andre.

Inkluderingen av og kompatibiliteten med internasjonale e-postadresser varierer fra leverandør til leverandør. Selv noen av de største leverandørene er ikke fullt kompatible med internasjonale adresser. For eksempel lar Google deg sende en e-post til en internasjonal adresse, men det tillater deg ikke å opprette en. Outlook 2016 har en lignende funksjonalitet.

Konklusjon

I motsetning til domenenavndelen er den lokale delen av en e-postadresse skiftende på små og store bokstaver. Når det er sagt, velger mange e-postleverandører å ignorere saksfølsomheten til den lokale delen av praktiske årsaker og oppfordrer folk til å opprette e-post kun med små bokstaver.

Interessante Artikler

Redaksjonens

Dekorer Windows 10 til jul og nyttår
Dekorer Windows 10 til jul og nyttår
Det er på tide å dekorere Windows 10 Desktop for feiring av jul og det kommende nyttåret. De fleste dekorerer husene sine med et juletre, opplyste kanker, snømenn og andre figurer. Hvis du også vil få PCen din i julefeiringen, har vi et sett med veldig spesielle godbiter for deg.
Hva du skal gjøre hvis det ikke kommer lyd fra Vizio TV-en
Hva du skal gjøre hvis det ikke kommer lyd fra Vizio TV-en
Vizio er et TV-merke som dukket opp i 2002 og raskt ble en stor aktør på det innenlandske TV-markedet. Selv om selve TV-ene er laget på lisens i Kina, er Vizio selv basert i Irvine, California, og
Kan du legge PC-en din på teppe – er den bra eller dårlig? [Forklart]
Kan du legge PC-en din på teppe – er den bra eller dårlig? [Forklart]
Hvordan laste ned en TikTok til MP3
Hvordan laste ned en TikTok til MP3
Alle elsker å lage og dele videoer på nettet med TikTok, spesielt de med engasjerende musikk og vokal. Hvis du vil lagre lyden fra TikTok-videoer, hjelper det å konvertere den til MP3-format. Dette lar deg bruke
Last ned Windows 10 Build 18290 offisielle ISO-bilder
Last ned Windows 10 Build 18290 offisielle ISO-bilder
Microsoft ga i dag ut de offisielle ISO-bildene for Windows 10 Build 18290, som representerer Windows 10-kodenavnet '19H1', den kommende funksjonsoppdateringen, også kjent som 'versjon 1903'. Den opprinnelige versjonen av Windows 10 Build 18290 ble utgitt 28. november 2018. De medfølgende ISO-bildene kommer med en oppdatert utløpsdato. Nedlastingen er tilgjengelig
Slik streamer du Netflix på Kodi
Slik streamer du Netflix på Kodi
Med så mange online streamingtjenester er det vanskelig å velge de å stole på. Heldigvis, takket være Kodi, er det nå mye lettere å gå fra den ene tjenesten til den andre. Hvis du ikke har hørt det, er Kodi et media
Hvordan spille Killer in Dead by Daylight
Hvordan spille Killer in Dead by Daylight
Dead by Daylight er et av de mest morsomme skrekkspillene med et bredt spekter av drapsmenn inspirert av kjente figurer fra filmer og bøker. Å spille en overlevende i et slikt spill kan selvfølgelig være ekstremt stressende, noe som betyr at